Which web browsers does Chaser work with?

We support Internet Explorer versions 10 and higher (inducing Microsoft Edge), Firefox versions 30 and higher and Safari versions 6 and higher. Chrome updates automatically, and we will always support the current version. Please also note that at present this does not include the mobile versions of these browsers.


We will try our best to ensure Chaser works with other browsers, but unfortunately there is a limit to the range of browsers we have the capacity to fully support. If you encounter any issues, please do let us know at support@chaserhq.com.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk