Browser Compatibility

We support the latest versions of Chrome, Safari, Microsoft Edge and Firefox. 

You can check if you are up to date with your browser by visiting their website: 

You can still access Chaser using older versions, but you should expect a more limited functionality. We recommend that you stay up to date with the latest version of your browser to get the most out of Chaser. 

 

We no longer support Internet Explorer. Click here for more information and advice about this.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk